Skip to content

mod_unique_id Error After Installing mod_security

Nov 5, 2009 1 min read #apache

This post is more than 18 months old. Technology changes quickly, so some of this content may be out of date (but that's not always the case). Please verify any technical or programming information against the current release.

After installing my mod_security module for apache, I could not restart my apache server.

I kept getting the following error:

[alert] (EAI 2)Name or service not known: mod_unique_id: unable to find IPv4 address of "mn-ws"
output

In this case, mn-ws was the host name of my computer.

This is a pretty simple fix, but I’ll document it anyway. The issue was that my host name was not looking up to my server.

First, I executed the hostname command. This reported back mn-ws properly. Then, I tried to ping mn-ws with no reply. I finally put an entry in the /etc/hosts file with the following content:

/etc/hosts
txt
127.0.0.1 mn-ws

This solved the issue and mod_security would now allow the server to start. Pretty simple.